Forum

Premium URL Shorten...
 
Notifications
Clear all

⚠️ 🚨 Hi H-educaters! Moderators will delete all posts with BAD ENGLISH OR GRAMMAR.🚨 ⚠️

Premium URL Shortener "URL not found"

Phil
 Phil
(@phil)
New Member

Following your video “How To Build Your URL Short System (Premium URL Shortening Setup)” i replicate it exactly.
Everything’s went fine until it needed to past the few lines (19:32 on your video) in apache2/sites-unabled/000-default.conf
In fact, in the folder apache/sites-unabled, there nothing, the folder is empty.
I found the file “000-default.conf” in the folder apache2/sites-available, i make the changes on the file, try to move the file
to sites-unabled (then restart apache) folder but no success, the links pricing, blog, login & Get Started still fall on a error page. bellow what’s it displays.
In addition the Shortener module displayed on the landing page doesn’t work…

<h1>Not Found</h1>
The requested URL was not found on this server.

Apache/2.4.41 (Ubuntu) Server at “site name” Port 80
i was able to already put the system online ONLY because of your great explanations.
I’m wondering if i miss something, or if there was any changes in the way to get it done since you publish your video?

Quote
Topic starter Posted : 12/01/2021 8:41 am
Phil
 Phil
(@phil)
New Member

In order to be absolutely sure, i reinstall a blank server on Contabo and went again step by step to the complete process.

everything's went perfect, the install files was deleted and the site is now live, however, all the links return to the same "Not Found" page.

In the folder Sites-enabled, there's a EMPTY FOLDER   000-default.conf    but no files with such name

A file    000-default.conf    is present in the FOLDER Sites-available

I don't want to mess with anything at this point so ....thanks in advance

ReplyQuote
Topic starter Posted : 12/01/2021 2:56 pm
Hasan AboulHasan
(@admin)
Illustrious Member

Hi friend, you just need to copy the lines from my blog guide and restart apache service, as mentioned in the blog guide, did you check it?

ReplyQuote
Posted : 13/01/2021 2:44 pm
arun
 arun
(@arun)
Eminent Member

HI Hasan,

 

I am also having the same problem. I copied the below tags in 000-default.conf and restarted the apache service. I am still getting URL not found issue.

Also, Is it a good and safe to give our ftp credentials (root access) to premium URL support team to further investigate?

 

<Directory /var/www/html/>
Options +FollowSymlinks
AllowOverride All
Require all granted
</Directory>

Arun

ReplyQuote
Posted : 15/01/2021 6:02 am
Hasan AboulHasan
(@admin)
Illustrious Member

Runt these commands:

sudo a2enmod rewrite
sudo systemctl restart apache2.service
ReplyQuote
Posted : 15/01/2021 9:24 pm

Share: