“No DKIM keys saved for this domain” for Office365 DKim

Home Forums Email Marketing General Support – Open “No DKIM keys saved for this domain” for Office365 DKim

Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #629

    While Setting up Office365 following this video

    In the Dkim Setup, it shows this:

    No dkim saved for this domain

    Any solution?

    #630

    Sometimes a newly added domain in Microsoft Office365 will not let you enable DKIM from the web user interface.

    YOu can Enable Dkim Keys, by manually creating it.

    On Your Windows PC, Open Powershell as administrator

    open powershell office365 dkim fix

    Then run the following commands one by one:

    Command 1:

    $UserCredential = Get-Credential

    Enter your outlook account credentials

    Command 2:

    $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid/ -Credential $UserCredential -Authentication Basic -AllowRedirection

    Command 3:

    Import-PSSession $Session -DisableNameChecking

    Wait for the process to finish, then run the following:

    New-DkimSigningConfig -DomainName “mydomain.tld” -Enabled $true

    *Replace mydomain.tld with your domain

    This command will succeed in generating the DKIM keys

    Last Command:

    Remove-PSSession $Session

    Now go to your office365 admin center, and check dkim settings.

    Don’t forget to copy DNS records as explained in the video tutorial.

     

    #710
    Up
    0
    Down
    Avatarrjagen@gmail.com
    Participant

    Hi Hassan, Encountered below error when setting up using Windows Power Shell

    Error

    Attachments:
    You must be logged in to view attached files.
    #731

    Its giving error and I’m unable to get the Enable button for DKIM

    Please Advice!

    #751

    for this problem: Files cannot be loaded because running scripts is disabled on this system.

    By default, Windows PowerShell isn’t configured to run scripts.

    to enable the usage of scripts you’ll need to run PowerShell as Administrator.

    Once PowerShell is open run the following command.

    Set-ExecutionPolicy RemoteSigned

    You’ll only need to run this once per machine and will be able to run scripts from now on.

    #794

    Dear Hassan. thanks for the tutorial, but i got this error while running this command – Import-PSSession $Session -DisableNameChecking – when trying to enable dkim using powershell

    Attachments:
    You must be logged in to view attached files.
    #806

    hello, any reply on the above?

    #812

    I really didnt face such an issue before.

    can you try again, or from another PC.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.