Postal DNS Setup and Test Send Mail

Home Forums Email Marketing General Support – Open Postal DNS Setup and Test Send Mail

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #839

    Hi Hasan

    Thanks for video about postal open source SMTP

    I try to install this on my labs, but i have problem with DNS Setup. I have configure MX and SPF on my dns server but when i check my record for SPF is still warning like this “An SPF record exists but it doesn’t include spf.postal.example.com ”

    And then i try to send mail using telnet but i get this error like this “530 From/Sender name is not valid”

    Maybe you have experience like that? Thank you

    Attachments:
    You must be logged in to view attached files.
    #865

    I need to see your SPF, please paste it here to check

    #928

    Hi Hasan,

     

    Thanks for your response.

    I still using DNS internal to test this postal, so we can’t check from public, we attach the spf check using dig

    user1@smtp1:~$ dig txt domain.tld

    ; <<>> DiG 9.10.3-P4-Ubuntu <<>> txt domain.tld
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40481
    ;; flags: qr aa rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 1280
    ;; QUESTION SECTION:
    ;domain.tld. IN TXT

    ;; ANSWER SECTION:
    domain.tld. 0 IN TXT “v=spf1 a mx include:spf:domain.tld ~all”

    ;; Query time: 0 msec
    ;; SERVER: 192.168.0.20#53(192.168.0.20)
    ;; WHEN: Wed Jul 01 13:17:11 WIB 2020
    ;; MSG SIZE rcvd: 93

     

    please advise. Thankyou

    #948

    do you mean you are using a private server??

    if yes, this will now work, you need a public IP

    #979

    Yes, this is private server on our lab to testing.

    If we are on private server, can this server work?

    cause we have mail server on private network to test and our dns is redirect to dns internal.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.