SMTP Server Installation Problem

Forums Email Marketing SMTP Servers SMTP Server Installation Problem

  • Post
    c23beto
    Participant
    Hello,

    I’m following this article: https://blog.h-educate.com/smtp-server-configuration/

    I’m at the SMTP Server Installation step (Step 1: Create Database). When I enter the command:

    sudo mysql -u root -p

    it asks for a password. I entered my VPS server password and Maria DB comes up. Then, I cannot enter the commands that follow in your guide because the prompt to enter a command does not come up.

    All the steps leading up to this step seemed to work with no issues.

    Could you help me understand what I am doing wrong.

    Thank you so much!

    Albert

    0
    0
Viewing 5 replies - 1 through 5 (of 5 total)
  • Replies
    abdallahTaleb
    Participant
    none
    This is correct, if Maria DB opens, then you should add the commands inside it. Are there any screenshots? Did you try to add any command and got an error?
    0
    0
    c23beto
    Participant
    Hello Abdallah,

    I cannot attach a screenshot because I am not allowed. I did enter commands in Maria DB and did get an error message:

    ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your Maria DB server version for the right syntax to user near ‘DATABASE postal CHARSET utf8mb4 COLLATE utf8mb4_unicode_ci’ at line 1

    Looking back at my steps, this came up after I typed in this command:

    utf8mb4_unicode_ci;

    The first command (sudo mysql -u root -p) prompted to “Enter password:”.

    After I typed my VPS server password, I entered the (utf8mb4_unicode_ci;) command.

    Please advise.

    Thank you for your time.

    Albert

    0
    0
    sachi0066@gmail.com
    Participant
    Hello Sir,

    I am trying to install postal on ubuntu 18.04 getitng below error. any suggestions on this please.

    i am using steps mentioned in below link.

    E: The repository ‘http://www.rabbitmq.com/debian testing Release’ does not have a Release file.
    N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    root@vmi532412:~#

    0
    0
    abdallahTaleb
    Participant
    none
    @C23BETO, I am not sure what you mean. You can remove the database system and try to install it again.

    @sachi0066@gmail.com, reinstall the VPS os and use below tutorial instead.

    https://blog.h-educate.com/smtp-server-configuration/

    0
    0
    c23beto
    Participant
    Abdallah,

    Would I have to go back to Step 1: Install Maria DB Server of the guide and start by entering command “sudo apt update”?

    If not, how do I remove the database?

    Thank you.

     

    0
    0
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.